[CLN-list] Overriding read_number_bad_syntax on OS X
Ron Garret
ron at flownet.com
Fri May 18 01:41:19 CEST 2007
On May 17, 2007, at 3:52 PM, Richard B. Kreckel wrote:
> Ron, the patch should work for your input routines. How does it
> work for you?
Like a charm, except for one thing. This code snippet:
class out_of_range {};
extern out_of_range range_exception;
now results in this error (referring to the second line):
error: 'out_of_range' does not name a type
This used to work, and if I rename out_of_range to Out_of_range then
it works again. So it appears that you made some change to the
include file that makes this break, but I can't for the life of me
figure out what it might be since nothing even remotely resembling
the string "out_of_range" appears anywhere in cln/*.h.
C++ can be quite the infuriating programming language.
rg
More information about the CLN-list
mailing list